Issues with password reset emails

Incident Report for Bitso

Resolved

This issue has been resolved.
Posted Aug 19, 2025 - 07:25 UTC

Investigating

We are facing issues with password reset emails . Team is working on it and we will keep you posted .

We apologize for any inconvenience this may cause.
Posted Aug 19, 2025 - 06:52 UTC