Issues with Conversions

Incident Report for Bitso

Resolved

This incident has been resolved.
Posted May 08, 2026 - 09:04 UTC

Investigating

We're currently experiencing intermittent issues with the conversions feature due to an outage with one of our providers. Some conversions may fail or take longer than usual to complete. Our team is actively working to restore full service.

We apologize for any inconvenience this may cause and appreciate your understanding.

For further assistance, please contact our Customer Support team at https://support.bitso.com/
Posted May 08, 2026 - 04:44 UTC
This incident affected: Bitso Trading Engine 🚀.